]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/ocaml-http/debian/rules
This commit was manufactured by cvs2svn to create branch 'moogle'.
[helm.git] / helm / DEVEL / ocaml-http / debian / rules
diff --git a/helm/DEVEL/ocaml-http/debian/rules b/helm/DEVEL/ocaml-http/debian/rules
deleted file mode 100755 (executable)
index 498a554..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/usr/bin/make -f
-
-#export DH_VERBOSE=1
-export DH_COMPAT=4
-
-TARGETDIR = $(CURDIR)/debian/libhttp-ocaml-dev
-OCAML_LIB_DIR = $(shell ocamlc -where)
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE) all
-       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       -$(MAKE) distclean
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       $(MAKE) install DESTDIR=$(TARGETDIR)$(OCAML_LIB_DIR)
-       $(MAKE) doc
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installchangelogs 
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary install