]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gTopLevel/configure.ac
ocaml 3.09 transition
[helm.git] / helm / gTopLevel / configure.ac
index fa5e4034110bce3b23f8181b4e102015ea0e4234..27d1ac8df601b30f112d106cb36f7b91607b64fa 100644 (file)
@@ -1,5 +1,33 @@
 AC_INIT(gTopLevel.ml)
 
+AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
+if test $HAVE_OCAMLFIND = "yes"; then
+  OCAMLFIND="ocamlfind"
+else
+  AC_MSG_ERROR(could not find ocamlfind)
+fi
+OCAMLFIND_COMMANDS=""
+AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
+if test $HAVE_OCAMLC_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
+  fi
+fi
+AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
+if test $HAVE_OCAMLOPT_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
+  fi
+fi
+if test "$OCAMLFIND_COMMANDS" != ""; then
+  OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
+fi
+
+
 AC_ARG_WITH(term-editor,
              AS_HELP_STRING([--with-term-editor=(tex|textual)],
                             [choose term editor (default is tex)]),
@@ -32,20 +60,6 @@ else
   fi
 fi
 
-AC_ARG_WITH(transformer,
-             AS_HELP_STRING([--with-transformer=(xslt|ocaml)],
-                            [choose mathml transformer (default is ocaml)]),
-             [TRANSFORMER=$withval], [TRANSFORMER=ocaml])
-if test $TRANSFORMER = "xslt"; then
-  CHOSEN_TRANSFORMER="include ApplyStylesheets"
-else
-  if test $TRANSFORMER = "ocaml"; then
-    CHOSEN_TRANSFORMER="include ApplyTransformation"
-  else
-    AC_MSG_ERROR(unknwon transformer $TRANSFORMER)
-  fi
-fi
-
 if test $TERM_EDITOR = "tex"; then
   CHOSEN_TERM_EDITOR="include TexTermEditor"
 else
@@ -56,12 +70,11 @@ else
   fi
 fi
 
+AC_SUBST(OCAMLFIND)
 AC_SUBST(CHOSEN_TERM_EDITOR)
 AC_SUBST(CHOSEN_TERM_PARSER)
-AC_SUBST(CHOSEN_TRANSFORMER)
 
 AC_OUTPUT([
-  chosenTransformer.ml
   chosenTermEditor.ml
   disambiguatingParser.ml
   Makefile