]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gTopLevel/configure.ac
detects and uses {ocamlc,ocamlopt}.opt when available
[helm.git] / helm / gTopLevel / configure.ac
index fa5e4034110bce3b23f8181b4e102015ea0e4234..2cddc9dbed4004cdcb28b09eba877e14c09bcdd2 100644 (file)
@@ -1,5 +1,33 @@
 AC_INIT(gTopLevel.ml)
 
+AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
+if test $HAVE_OCAMLFIND = "yes"; then
+  OCAMLFIND="ocamlfind"
+else
+  AC_MSG_ERROR(could not find ocamlfind)
+fi
+OCAMLFIND_COMMANDS=""
+AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
+if test $HAVE_OCAMLC_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
+  fi
+fi
+AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
+if test $HAVE_OCAMLOPT_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
+  fi
+fi
+if test "$OCAMLFIND_COMMANDS" != ""; then
+  OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
+fi
+
+
 AC_ARG_WITH(term-editor,
              AS_HELP_STRING([--with-term-editor=(tex|textual)],
                             [choose term editor (default is tex)]),
@@ -56,6 +84,7 @@ else
   fi
 fi
 
+AC_SUBST(OCAMLFIND)
 AC_SUBST(CHOSEN_TERM_EDITOR)
 AC_SUBST(CHOSEN_TERM_PARSER)
 AC_SUBST(CHOSEN_TRANSFORMER)