]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gTopLevel/configure.ac
added Makefile.in
[helm.git] / helm / gTopLevel / configure.ac
index aaa661e0aee38df671c19e399e75d99913c198b3..fa5e4034110bce3b23f8181b4e102015ea0e4234 100644 (file)
@@ -46,6 +46,16 @@ else
   fi
 fi
 
+if test $TERM_EDITOR = "tex"; then
+  CHOSEN_TERM_EDITOR="include TexTermEditor"
+else
+  if test $TERM_EDITOR = "textual"; then
+    CHOSEN_TERM_EDITOR="include TermEditor"
+  else
+    AC_MSG_ERROR(unknwon term editor $TERM_EDITOR)
+  fi
+fi
+
 AC_SUBST(CHOSEN_TERM_EDITOR)
 AC_SUBST(CHOSEN_TERM_PARSER)
 AC_SUBST(CHOSEN_TRANSFORMER)
@@ -54,5 +64,6 @@ AC_OUTPUT([
   chosenTransformer.ml
   chosenTermEditor.ml
   disambiguatingParser.ml
+  Makefile
 ])