]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gtkmathview-bonobo/configure.ac
This commit was manufactured by cvs2svn to create branch
[helm.git] / helm / gtkmathview-bonobo / configure.ac
diff --git a/helm/gtkmathview-bonobo/configure.ac b/helm/gtkmathview-bonobo/configure.ac
deleted file mode 100644 (file)
index 7eee268..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(gtkmathview-bonobo, [0.0.1])
-AC_CONFIG_SRCDIR(src/GNOME_GtkMathView.server.in)
-AM_INIT_AUTOMAKE($AC_PACKAGE_NAME, $AC_PACKAGE_VERSION)
-
-PACKAGE=$PACKAGE_NAME
-VERSION=$PACKAGE_VERSION
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-
-GTKMATHVIEW_CONTROL_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
-AC_SUBST(GTKMATHVIEW_CONTROL_VERSION_INFO)
-
-GTKMATHVIEW_API_VERSION="1.0"
-AC_SUBST(GTKMATHVIEW_API_VERSION)
-AC_DEFINE_UNQUOTED(MATH_VIEW_API_VERSION, "$GTKMATHVIEW_API_VERSION", [Version number of the API implemented])
-
-AC_ARG_ENABLE(
-       profile,
-       [  --enable-profile[=ARG]  include profiling information [default=no]],
-       profile=$enableval,
-       profile=no
-)
-
-AC_ARG_ENABLE(
-       debug,
-       [  --enable-debug[=ARG]    include debugging debug [default=yes]],
-       enable_debug=$enableval,
-       enable_debug=yes
-)
-
-if test "x$enable_debug" = "xyes"; then
-   AC_DEFINE(ENABLE_DEBUG,,[Define to 1 if you want to enable validity checks while running])
-fi
-
-dnl AC_CONFIG_HEADERS([config.h])
-AM_CONFIG_HEADER(config.h)
-
-AH_TOP([
-/* This file is part of GtkMathView-Bonobo, an implementation of
- * some Bonobo interfaces for GtkMathView.
- * 
- * Copyright (C) 2003 Luca Padovani <lpadovan@cs.unibo.it>,
- *                    Pouria Masoudi <pmasoudi@cs.unibo.it>.
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
- * License as published by the Free Software Foundation; either
- * version 2.1 of the License, or (at your option) any later version.
- *
- * This library is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
- * Lesser General Public License for more details.
- *
- * You should have received a copy of the GNU Lesser General Public
- * License along with this library; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
- *
- * For more information, please visit the project's home page
- * http://helm.cs.unibo.it/gtkmathview-bonobo/
- * or send an email to <lpadovan@cs.unibo.it>
- */
-
-#ifndef config_h
-#define config_h
-])
-
-AH_BOTTOM([
-#endif /* config_h */
-])
-
-AC_PROG_CC
-AC_PROG_CXX
-AC_PROG_INSTALL
-AC_HEADER_STDC([])
-
-AC_SUBST(CFLAGS)
-AC_SUBST(CPPFLAGS)
-AC_SUBST(LDFLAGS)
-
-AM_PROG_LIBTOOL
-
-PKG_CHECK_MODULES(GTKMATHVIEW, gtkmathview >= 0.5.0)
-AC_SUBST(GTKMATHVIEW_CFLAGS)
-AC_SUBST(GTKMATHVIEW_LIBS)
-
-PKG_CHECK_MODULES(BONOBO, libbonobo-2.0)
-AC_SUBST(BONOBO_CFLAGS)
-AC_SUBST(BONOBO_LIBS)
-
-PKG_CHECK_MODULES(BONOBOUI, libbonoboui-2.0)
-AC_SUBST(BONOBOUI_CFLAGS)
-AC_SUBST(BONOBOUI_LIBS)
-
-PKG_CHECK_MODULES(GNOMEUI, libgnomeui-2.0)
-AC_SUBST(GNOMEUI_CFLAGS)
-AC_SUBST(GNOMEUI_LIBS)
-
-AC_CONFIG_FILES([
- Makefile 
- gtkmathview-bonobo.pc
- src/Makefile
- src/GNOME_GtkMathView.server
- test/Makefile
-])
-AC_OUTPUT