]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gtkmathview-bonobo/configure.ac
ocaml 3.09 transition
[helm.git] / helm / gtkmathview-bonobo / configure.ac
index 6f3c1596f9a00db0f714cf38a91855e1aaf0ff7f..e30b55212778810961d20b63e721a4a7c74e2e35 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_INIT(gtkmathview-bonobo, [0.0.1])
-AC_CONFIG_SRCDIR(src/GNOME_GtkMathView.server.in)
+AC_INIT(gtkmathview-bonobo, [0.0.3])
+AC_CONFIG_SRCDIR(src/GNOME_GtkMathView.server.in.in)
 AM_INIT_AUTOMAKE($AC_PACKAGE_NAME, $AC_PACKAGE_VERSION)
 
 PACKAGE=$PACKAGE_NAME
@@ -8,8 +8,12 @@ VERSION=$PACKAGE_VERSION
 AC_SUBST(PACKAGE)
 AC_SUBST(VERSION)
 
-GTKMATHVIEW_BONOBO_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
-AC_SUBST(GTKMATHVIEW_BONOBO_VERSION_INFO)
+GTKMATHVIEW_CONTROL_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
+AC_SUBST(GTKMATHVIEW_CONTROL_VERSION_INFO)
+
+GTKMATHVIEW_API_VERSION="1.0"
+AC_SUBST(GTKMATHVIEW_API_VERSION)
+AC_DEFINE_UNQUOTED(MATH_VIEW_API_VERSION, "$GTKMATHVIEW_API_VERSION", [Version number of the API implemented])
 
 AC_ARG_ENABLE(
        profile,
@@ -33,28 +37,26 @@ dnl AC_CONFIG_HEADERS([config.h])
 AM_CONFIG_HEADER(config.h)
 
 AH_TOP([
-/* This file is part of GtkMathView-Bonobo, an implementation of
- * some Bonobo interfaces for GtkMathView.
+/* This file is part of GtkMathView-Bonobo, a Bonobo wrapper for GtkMathView.
+ * Copyright (C) 2003 Luca Padovani <lpadovan@cs.unibo.it>
+ *                    Pouria Masoudi <pmasoudi@cs.unibo.it>
  * 
- * Copyright (C) 2003 Luca Padovani <lpadovan@cs.unibo.it>,
- *                    Pouria Masoudi <pmasoudi@cs.unibo.it>.
- *
  * This library is free software; you can redistribute it and/or
  * modify it under the terms of the GNU Lesser General Public
  * License as published by the Free Software Foundation; either
  * version 2.1 of the License, or (at your option) any later version.
- *
+ * 
  * This library is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
  * Lesser General Public License for more details.
- *
+ * 
  * You should have received a copy of the GNU Lesser General Public
  * License along with this library; if not, write to the Free Software
  * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
  *
  * For more information, please visit the project's home page
- * http://helm.cs.unibo.it/gtkmathview-bonobo/
+ * http://helm.cs.unibo.it/gtkmathview-bonobo
  * or send an email to <lpadovan@cs.unibo.it>
  */
 
@@ -77,7 +79,7 @@ AC_SUBST(LDFLAGS)
 
 AM_PROG_LIBTOOL
 
-PKG_CHECK_MODULES(GTKMATHVIEW, gtkmathview >= 0.4.3)
+PKG_CHECK_MODULES(GTKMATHVIEW, gtkmathview >= 0.5.1)
 AC_SUBST(GTKMATHVIEW_CFLAGS)
 AC_SUBST(GTKMATHVIEW_LIBS)
 
@@ -89,9 +91,22 @@ PKG_CHECK_MODULES(BONOBOUI, libbonoboui-2.0)
 AC_SUBST(BONOBOUI_CFLAGS)
 AC_SUBST(BONOBOUI_LIBS)
 
+PKG_CHECK_MODULES(GNOMEUI, libgnomeui-2.0)
+AC_SUBST(GNOMEUI_CFLAGS)
+AC_SUBST(GNOMEUI_LIBS)
+
+ORBIT_IDL="`$PKG_CONFIG --variable=orbit_idl ORBit-2.0`"
+AC_SUBST(ORBIT_IDL)
+
+BONOBO_IDL_INCLUDES="-I`$PKG_CONFIG --variable=idldir libbonobo-2.0` -I`$PKG_CONFIG --variable=idldir bonobo-activation-2.0`"
+AC_SUBST(BONOBO_IDL_INCLUDES)
+
 AC_CONFIG_FILES([
  Makefile 
+ gtkmathview-bonobo.pc
+ idl/Makefile
  src/Makefile
- src/GNOME_GtkMathView.server
+ src/GNOME_GtkMathView.server.in
+ test/Makefile
 ])
 AC_OUTPUT