]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gtkmathview-bonobo/src/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / gtkmathview-bonobo / src / Makefile.am
index 4de86a0b73d6e4f1789d84581001876decabe121..92e6a969039b0ccfdfd89d5317c7756cf78fa8cd 100644 (file)
@@ -3,20 +3,22 @@ location = $(libdir)/libgtkmathview-bonobo.so
 serverdir = $(libdir)/bonobo/servers
 server_in_files = GNOME_GtkMathView.server.in.in
 
-CLEANFILES = $(server_in_files:.server.in.in=.server)
-
 IDL = $(top_srcdir)/idl/GtkMathView.idl
 
 IDL_GENERATED_C = \
-  GNOME_GtkMathView_View-common.c \
-  GNOME_GtkMathView_View-skels.c \
-  GNOME_GtkMathView_View-stubs.c
+  GtkMathView-common.c \
+  GtkMathView-skels.c \
+  GtkMathView-stubs.c
 
 IDL_GENERATED_H = \
-  GNOME_GtkMathView_View.h
+  GtkMathView.h
 
 IDL_GENERATED = $(IDL_GENERATED_C) $(IDL_GENERATED_H)
 
+CLEANFILES = \
+  $(server_in_files:.server.in.in=.server) \
+  $(IDL_GENERATED)
+
 lib_LTLIBRARIES = libgtkmathview-bonobo.la
 
 libgtkmathview_bonobo_la_LIBADD = \
@@ -36,12 +38,17 @@ libgtkmathview_bonobo_la_SOURCES = \
   handlers.c \
   view.c
 
-pkginclude_HEADERS = \
+noinst_HEADERS = \
+  control-data.h \
   control-factory.h \
   persist-file.h    \
   persist-stream.h  \
   handlers.h \
-  view.h
+  view.h \
+  aux.h
+
+pkginclude_HEADERS = \
+  $(IDL_GENERATED_H)
 
 server_DATA = $(server_in_files:.server.in.in=.server)
 $(server_in_files:.server.in.in=.server): $(server_in_files:.server.in.in=.server.in) Makefile