]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/gtkmathview-bonobo/src/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / gtkmathview-bonobo / src / Makefile.am
index e211a3861bd35236d42d75bd5d2ca22b93b03550..92e6a969039b0ccfdfd89d5317c7756cf78fa8cd 100644 (file)
@@ -3,25 +3,64 @@ location = $(libdir)/libgtkmathview-bonobo.so
 serverdir = $(libdir)/bonobo/servers
 server_in_files = GNOME_GtkMathView.server.in.in
 
-CLEANFILES = $(server_in_files:.server.in.in=.server)
+IDL = $(top_srcdir)/idl/GtkMathView.idl
+
+IDL_GENERATED_C = \
+  GtkMathView-common.c \
+  GtkMathView-skels.c \
+  GtkMathView-stubs.c
+
+IDL_GENERATED_H = \
+  GtkMathView.h
+
+IDL_GENERATED = $(IDL_GENERATED_C) $(IDL_GENERATED_H)
+
+CLEANFILES = \
+  $(server_in_files:.server.in.in=.server) \
+  $(IDL_GENERATED)
 
 lib_LTLIBRARIES = libgtkmathview-bonobo.la
 
-libgtkmathview_bonobo_la_LIBADD = $(GTKMATHVIEW_LIBS) $(BONOBOUI_LIBS) $(BONOBO_LIBS)
+libgtkmathview_bonobo_la_LIBADD = \
+  $(GTKMATHVIEW_LIBS) \
+  $(BONOBOUI_LIBS) \
+  $(BONOBO_LIBS)
+
 libgtkmathview_bonobo_la_LDFLAGS = -version-info @GTKMATHVIEW_CONTROL_VERSION_INFO@
 
 libgtkmathview_bonobo_la_SOURCES = \
+  $(IDL_GENERATED_C) \
+  control-data.c \
   control-factory.c \
-  persist-file.c
+  persist-file.c \
+  persist-stream.c \
+  aux.cc \
+  handlers.c \
+  view.c
 
-pkginclude_HEADERS = \
+noinst_HEADERS = \
+  control-data.h \
   control-factory.h \
-  persist-file.h
+  persist-file.h    \
+  persist-stream.h  \
+  handlers.h \
+  view.h \
+  aux.h
+
+pkginclude_HEADERS = \
+  $(IDL_GENERATED_H)
 
 server_DATA = $(server_in_files:.server.in.in=.server)
 $(server_in_files:.server.in.in=.server): $(server_in_files:.server.in.in=.server.in) Makefile
        sed -e "s|\@GTKMATHVIEW_FACTORY_LOCATION\@|$(location)|g" $< >$@
 
+view.c : $(VIEW_CORBA_GENERATED)
+
+$(IDL_GENERATED): $(IDL)
+       $(ORBIT_IDL) $(BONOBO_IDL_INCLUDES) $<
+
+EXTRA_DIST = $(server_DATA)
+
 INCLUDES = \
   $(BONOBOUI_CFLAGS) \
   $(BONOBO_CFLAGS) \