]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/helm_data/configure.in
This commit was manufactured by cvs2svn to create branch 'init'.
[helm.git] / helm / helm_data / configure.in
diff --git a/helm/helm_data/configure.in b/helm/helm_data/configure.in
deleted file mode 100644 (file)
index 6352589..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-AC_INIT(dtd/cic.dtd)
-
-PACKAGE=helm_data
-MAJOR_VERSION=0
-MINOR_VERSION=0
-MICRO_VERSION=2
-VERSION=$MAJOR_VERSION.$MINOR_VERSION.$MICRO_VERSION
-
-DEFAULT_HELM_DTD_DIR=/usr/local/share/helm/dtd
-DEFAULT_HELM_STYLE_DIR=/usr/local/share/helm/style
-
-AC_ARG_ENABLE(
-       defaults,
-       [  --enable-defaults[=ARG] if yes then use defaults (don't ask user) [default=auto]],
-       USE_DEFAULTS=$enableval,
-       USE_DEFAULTS=auto
-)
-
-if test $USE_DEFAULTS = auto; then
-       AC_CHECK_PROG(HAVE_HELM_CONFIG, helm-config, yes, no)
-       if test $HAVE_HELM_CONFIG = yes; then
-               HELM_DTD_DIR=`helm-config --dtd-dir`
-               HELM_STYLE_DIR=`helm-config --style-dir`
-       else
-               USE_DEFAULTS=no
-       fi
-fi
-
-if test $USE_DEFAULTS = no; then
-       echo
-       echo "\`helm-config' is not installed (or I can't find it in your path)."
-       echo "Please, insert the directory where I can find the DTDs for HELM..."
-       echo
-       echo -n "[[$DEFAULT_HELM_DTD_DIR]] ? "
-       read HELM_DTD_DIR
-       if test "x$HELM_DTD_DIR" = "x"; then
-               HELM_DTD_DIR=$DEFAULT_HELM_DTD_DIR
-       fi
-       echo
-       echo "Please, insert the directory where I can find the stylesheets for HELM..."
-       echo
-       echo -n "[[$DEFAULT_HELM_STYLE_DIR]] ? "
-       read HELM_STYLE_DIR
-       if test "x$HELM_STYLE_DIR" = "x"; then
-               HELM_STYLE_DIR=$DEFAULT_HELM_STYLE_DIR
-       fi
-elif test $USE_DEFAULTS = yes; then
-       HELM_DTD_DIR=$DEFAULT_HELM_DTD_DIR
-       HELM_STYLE_DIR=$DEFAULT_HELM_STYLE_DIR
-fi
-
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-AC_SUBST(HELM_DTD_DIR)
-AC_SUBST(HELM_STYLE_DIR)
-
-AC_OUTPUT([
-  Makefile
-  helm_data.spec
-])
-