]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/helmpot/configure.in
This commit was manufactured by cvs2svn to create branch
[helm.git] / helm / helmpot / configure.in
diff --git a/helm/helmpot/configure.in b/helm/helmpot/configure.in
deleted file mode 100644 (file)
index 3d31a0d..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(main.c)
-
-HELMPOT_MAJOR_VERSION=0
-HELMPOT_MINOR_VERSION=1
-HELMPOT_MICRO_VERSION=0
-HELMPOT_VERSION=$HELMPOT_MAJOR_VERSION.$HELMPOT_MINOR_VERSION.$HELMPOT_MICRO_VERSION
-VERSION=$HELMPOT_VERSION
-
-AC_SUBST(HELMPOT_VERSION)
-
-AC_ARG_ENABLE(
-       checks,
-       [  --enable-checks[=ARG]   include debugging checks [default=yes]],
-       [
-               if test $enableval = yes; then
-                       AC_DEFINE(ENABLE_CHECKS)
-               fi
-       ],
-       AC_DEFINE(ENABLE_CHECKS)
-)
-
-dnl Automake configuration
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(helmpot, $HELMPOT_VERSION)
-
-dnl Checks for programs.
-AC_LANG_C
-AC_PROG_CC
-AC_ISC_POSIX
-AC_CHECK_PROG(HAVE_COLORGCC, colorgcc, yes, no)
-
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS(unistd.h)
-AC_FUNC_VFORK
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-
-dnl Check for iconv with const pointer as second argument
-AC_LANG_C
-
-dnl Checks for libraries
-AM_PATH_GTK(1.2.0, gtklib="yes", gtklib="no")
-
-if test $gtklib = "no"; then
-       AC_MSG_ERROR(GTK is needed in order to use helmpot)
-fi
-
-CFLAGS="$CFLAGS @GTKMATHVIEW_CFLAGS@"
-CXXFLAGS="$CXXFLAGS @GTKMATHVIEW_CFLAGS@"
-LIBS="$LIBS @GTKMATHVIEW_LIBS@"
-
-PKG_CHECK_MODULES(GTKMATHVIEW, gtkmathview >= 0.3.0,, AC_MSG_ERROR(could not find gtkmathview))
-AC_SUBST(GTKMATHVIEW_CFLAGS)
-AC_SUBST(GTKMATHVIEW_LIBS)
-
-if test $HAVE_COLORGCC = "yes"; then
-       CC=colorgcc
-       CXX=colorgcc
-fi
-
-CFLAGS="$CFLAGS -W -Wall"
-CXXFLAGS="$CXXFLAGS -W -Wall"
-
-AC_OUTPUT([
-Makefile
-helmpot.spec
-])