]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/helmpot/debian/rules
This commit was manufactured by cvs2svn to create branch
[helm.git] / helm / helmpot / debian / rules
diff --git a/helm/helmpot/debian/rules b/helm/helmpot/debian/rules
deleted file mode 100755 (executable)
index 75b3d8a..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=2
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
-       # Add here commands to compile the package.
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/tmp.
-       $(MAKE) install prefix=$(CURDIR)/debian/helmpot/usr
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-#      dh_installexamples
-#      dh_installmenu
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installinit
-#      dh_installcron
-#      dh_installmanpages
-       dh_installinfo
-       dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       # You may want to make some executables suid here.
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install