]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/matita/configure.ac
This commit was manufactured by cvs2svn to create branch 'moogle'.
[helm.git] / helm / matita / configure.ac
diff --git a/helm/matita/configure.ac b/helm/matita/configure.ac
deleted file mode 100644 (file)
index bfaea84..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-AC_INIT(matita.ml)
-
-AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
-if test $HAVE_OCAMLC = "no"; then
-  AC_MSG_ERROR(could not find ocamlc)
-fi
-AC_CHECK_PROG(HAVE_OCAMLOPT, ocamlopt, yes, no)
-if test $HAVE_OCAMLOPT = "no"; then
-  AC_MSG_WARN(could not find ocamlopt: native code compilation disabled)
-fi
-AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
-if test $HAVE_OCAMLFIND = "yes"; then
-  OCAMLFIND="ocamlfind"
-else
-  AC_MSG_ERROR(could not find ocamlfind)
-fi
-AC_CHECK_PROG(HAVE_LABLGLADECC, lablgladecc2, yes, no)
-if test $HAVE_LABLGLADECC = "yes"; then
-  LABLGLADECC="lablgladecc2"
-else
-  AC_MSG_ERROR(could not find lablgladecc2)
-fi
-AC_CHECK_PROG(HAVE_CAMLP4O, camlp4o, yes, no)
-if test $HAVE_CAMLP4O = "yes"; then
-  CAMLP4O="camlp4o"
-else
-  AC_MSG_ERROR(could not find camlp4o)
-fi
-
-FINDLIB_REQUIRES="\
-lablgtk2.glade \
-pcre \
-helm-cic_omdoc \
-helm-cic_transformations \
-helm-registry \
-helm-tactics \
-helm-xml \
-helm-disambiguator \
-helm-mathql_interpreter \
-"
-for r in $FINDLIB_REQUIRES
-do
-  AC_MSG_CHECKING(for $r ocaml library)
-  if $OCAMLFIND query $r &> /dev/null; then
-    AC_MSG_RESULT(yes)
-  else
-    AC_MSG_ERROR(could not find $r ocaml library)
-  fi
-done
-
-OCAMLFIND_COMMANDS=""
-AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
-if test $HAVE_OCAMLC_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
-  fi
-fi
-AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
-if test $HAVE_OCAMLOPT_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
-  fi
-fi
-if test "$OCAMLFIND_COMMANDS" != ""; then
-  OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
-fi
-AC_ARG_ENABLE(debug,
-  [  --enable-debug    Turn on debugging],
-  [case "${enableval}" in
-   yes) DEBUG=true ;;
-   no)  DEBUG=false ;;
-   *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
-  esac],
-  [DEBUG=true])
-if test "$DEBUG" = "true"; then
-  echo "debugging enabled"
-fi
-
-AC_SUBST(CAMLP4O)
-AC_SUBST(DEBUG)
-AC_SUBST(FINDLIB_REQUIRES)
-AC_SUBST(HAVE_OCAMLOPT)
-AC_SUBST(LABLGLADECC)
-AC_SUBST(OCAMLFIND)
-
-AC_OUTPUT([
-  buildTimeConf.ml
-  Makefile
-])