]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/matita/configure.ac
ocaml 3.09 transition
[helm.git] / helm / matita / configure.ac
index 4f8c991d1082d380e1fd4fe6bdcd089360e5d87e..d20bf2192224b1bd79463cfb5ce12c69c9bdf8fa 100644 (file)
@@ -1,5 +1,11 @@
 AC_INIT(matitaTypes.ml)
 
+# Distribution settings (i.e. settings to be manipulated before a release)
+DEBUG_DEFAULT="true"
+RT_BASE_DIR_DEFAULT="`pwd`"
+MATITA_VERSION="0.0.1"
+# End of distribution settings
+
 AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
 if test $HAVE_OCAMLC = "no"; then
   AC_MSG_ERROR(could not find ocamlc)
@@ -87,21 +93,31 @@ OCAMLFIND_COMMANDS=""
 if test "$OCAMLFIND_COMMANDS" != ""; then
   OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
 fi
+
+AC_MSG_CHECKING(--enable-debug argument)
 AC_ARG_ENABLE(debug,
-  [  --enable-debug    Turn on debugging],
-  [case "${enableval}" in
+  [  --enable-debug    Turn on debugging],
+  [GIVEN="yes";
+   case "${enableval}" in
    yes) DEBUG=true ;;
    no)  DEBUG=false ;;
    *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
   esac],
-  [DEBUG=true])
+  [GIVEN="no"; DEBUG="$DEBUG_DEFAULT"])
+MSG=$GIVEN
 if test "$DEBUG" = "true"; then
-  echo "debugging enabled"
+  MSG="$MSG, debugging enabled."
+else
+  MSG="$MSG, debugging disabled."
 fi
+AC_MSG_RESULT($MSG)
 
-RT_BASE_DIR=`pwd`
-USER_HOME=`pwd` #should be `echo $HOME`
-USER_NAME=`echo $USER`
+AC_MSG_CHECKING(--with-runtime-dir argument)
+AC_ARG_WITH(runtime-dir,
+  [ --with-runtime-dir Runtime directory (current working directory if not given)],
+  [ RT_BASE_DIR="${withval}" ],
+  [ RT_BASE_DIR="$RT_BASE_DIR_DEFAULT" ])
+AC_MSG_RESULT($RT_BASE_DIR)
 
 AC_SUBST(CAMLP4O)
 AC_SUBST(DEBUG)
@@ -115,8 +131,7 @@ AC_SUBST(HAVE_OCAMLOPT)
 AC_SUBST(LABLGLADECC)
 AC_SUBST(OCAMLFIND)
 AC_SUBST(RT_BASE_DIR)
-AC_SUBST(USER_HOME)
-AC_SUBST(USER_NAME)
+AC_SUBST(MATITA_VERSION)
 
 AC_OUTPUT([
   matita.conf.xml.sample