]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/matita/configure.ac
ocaml 3.09 transition
[helm.git] / helm / matita / configure.ac
index e25e1c65c1aa7e3e029ab0c0d676ded7477e87a4..d20bf2192224b1bd79463cfb5ce12c69c9bdf8fa 100644 (file)
@@ -1,5 +1,11 @@
 AC_INIT(matitaTypes.ml)
 
+# Distribution settings (i.e. settings to be manipulated before a release)
+DEBUG_DEFAULT="true"
+RT_BASE_DIR_DEFAULT="`pwd`"
+MATITA_VERSION="0.0.1"
+# End of distribution settings
+
 AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
 if test $HAVE_OCAMLC = "no"; then
   AC_MSG_ERROR(could not find ocamlc)
@@ -26,17 +32,25 @@ if test $HAVE_CAMLP4O = "yes"; then
 else
   AC_MSG_ERROR(could not find camlp4o)
 fi
-
-FINDLIB_CREQUIRES="\
+FINDLIB_COMREQUIRES="\
 pcre \
 mysql \
-unix \
-helm-cic_omdoc \
-helm-cic_transformations \
 helm-registry \
+helm-extlib \
+helm-hmysql \
+helm-cic_notation \
 helm-tactics \
-helm-xml \
-helm-cic_textual_parser2 \
+helm-cic_disambiguation \
+"
+FINDLIB_CLEANREQUIRES="$FINDLIB_COMREQUIRES"
+FINDLIB_DEPREQUIRES="$FINDLIB_COMREQUIRES"
+FINDLIB_MAKEREQUIRES=" \
+helm-registry \
+helm-extlib \
+"
+FINDLIB_CREQUIRES=" \
+$FINDLIB_COMREQUIRES \
+helm-paramodulation \
 "
 FINDLIB_REQUIRES="\
 $FINDLIB_CREQUIRES \
@@ -44,11 +58,15 @@ lablgtk2.glade \
 lablgtkmathview \
 lablgtksourceview \
 helm-xmldiff \
+helm-cic_transformations \
+helm-tactics \
+helm-cic_disambiguation \
+helm-paramodulation \
 "
 for r in $FINDLIB_REQUIRES
 do
   AC_MSG_CHECKING(for $r ocaml library)
-  if $OCAMLFIND query $r &> /dev/null; then
+  if OCAMLPATH=../ocaml/METAS $OCAMLFIND query $r &> /dev/null; then
     AC_MSG_RESULT(yes)
   else
     AC_MSG_ERROR(could not find $r ocaml library)
@@ -56,50 +74,68 @@ do
 done
 
 OCAMLFIND_COMMANDS=""
-AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
-if test $HAVE_OCAMLC_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
-  fi
-fi
-AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
-if test $HAVE_OCAMLOPT_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
-  fi
-fi
+AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
+if test $HAVE_OCAMLC_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
+  fi
+fi
+AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
+if test $HAVE_OCAMLOPT_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
+  fi
+fi
 if test "$OCAMLFIND_COMMANDS" != ""; then
   OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
 fi
+
+AC_MSG_CHECKING(--enable-debug argument)
 AC_ARG_ENABLE(debug,
-  [  --enable-debug    Turn on debugging],
-  [case "${enableval}" in
+  [  --enable-debug    Turn on debugging],
+  [GIVEN="yes";
+   case "${enableval}" in
    yes) DEBUG=true ;;
    no)  DEBUG=false ;;
    *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
   esac],
-  [DEBUG=true])
+  [GIVEN="no"; DEBUG="$DEBUG_DEFAULT"])
+MSG=$GIVEN
 if test "$DEBUG" = "true"; then
-  echo "debugging enabled"
+  MSG="$MSG, debugging enabled."
+else
+  MSG="$MSG, debugging disabled."
 fi
+AC_MSG_RESULT($MSG)
 
-RT_BASE_DIR="."
+AC_MSG_CHECKING(--with-runtime-dir argument)
+AC_ARG_WITH(runtime-dir,
+  [ --with-runtime-dir Runtime directory (current working directory if not given)],
+  [ RT_BASE_DIR="${withval}" ],
+  [ RT_BASE_DIR="$RT_BASE_DIR_DEFAULT" ])
+AC_MSG_RESULT($RT_BASE_DIR)
 
 AC_SUBST(CAMLP4O)
 AC_SUBST(DEBUG)
 AC_SUBST(TRANSFORMER_MODULE)
 AC_SUBST(FINDLIB_REQUIRES)
 AC_SUBST(FINDLIB_CREQUIRES)
+AC_SUBST(FINDLIB_DEPREQUIRES)
+AC_SUBST(FINDLIB_CLEANREQUIRES)
+AC_SUBST(FINDLIB_MAKEREQUIRES)
 AC_SUBST(HAVE_OCAMLOPT)
 AC_SUBST(LABLGLADECC)
 AC_SUBST(OCAMLFIND)
 AC_SUBST(RT_BASE_DIR)
+AC_SUBST(MATITA_VERSION)
 
 AC_OUTPUT([
+  matita.conf.xml.sample
   buildTimeConf.ml
   Makefile
+  gtkmathview.matita.conf.xml
 ])