]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/minidom/configure.in
ocaml 3.09 transition
[helm.git] / helm / minidom / configure.in
index 5e395485b8aaecc2264bce32ea27c03af3cdfe86..c6067b0ae88fa939ed54a1c8587f879ba1cffaa3 100644 (file)
@@ -3,7 +3,7 @@ AC_INIT(minidom.c)
 
 MINIDOM_MAJOR_VERSION=0
 MINIDOM_MINOR_VERSION=1
-MINIDOM_MICRO_VERSION=1
+MINIDOM_MICRO_VERSION=4
 MINIDOM_VERSION=$MINIDOM_MAJOR_VERSION.$MINIDOM_MINOR_VERSION.$MINIDOM_MICRO_VERSION
 MINIDOM_VERSION_INFO=`expr $MINIDOM_MAJOR_VERSION + $MINIDOM_MINOR_VERSION`:$MINIDOM_MICRO_VERSION:$MINIDOM_MINOR_VERSION
 
@@ -37,15 +37,17 @@ AC_CHECK_LIB(glib, g_malloc,
        `glib-config --libs`
 )
 
-AC_CHECK_PROG(XML_CONFIG, xml2-config, xml2-config)
-AC_CHECK_PROG(XML_CONFIG, xml-config, xml-config, no)
+AC_CHECK_PROG(XML_CONFIG, xml2-config, xml2-config, no)
+if test $XML_CONFIG = "no"; then
+       AC_CHECK_PROG(XML_CONFIG, xml-config, xml-config, no)
+fi
 AC_SUBST(XML_CONFIG)
 
 if test $XML_CONFIG = "no"; then
        AC_MSG_ERROR(could not find configuration script for libxml)
 fi
 
-if test $XML_CONFIG = xml2-config -a libxml2 = "auto"; then
+if test $XML_CONFIG = "xml2-config" -a $libxml2 = "auto"; then
        libxml2="yes"
 fi