]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/ocaml/configure.ac
This commit was manufactured by cvs2svn to create branch 'moogle'.
[helm.git] / helm / ocaml / configure.ac
diff --git a/helm/ocaml/configure.ac b/helm/ocaml/configure.ac
deleted file mode 100644 (file)
index 0651685..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-AC_INIT(Makefile.in)
-
-AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
-if test $HAVE_OCAMLC = "no"; then
-  AC_MSG_ERROR(could not find ocamlc in PATH, please make sure ocaml is installed)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
-if test $HAVE_OCAMLFIND = "no"; then
-  AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
-else
-  OCAMLFIND=ocamlfind
-fi
-
-OCAMLFIND_COMMANDS=""
-AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
-if test $HAVE_OCAMLC_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
-  fi
-fi
-AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
-if test $HAVE_OCAMLOPT_OPT = "yes"; then
-  if test "$OCAMLFIND_COMMANDS" = ""; then
-    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
-  else
-    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
-  fi
-fi
-if test "$OCAMLFIND_COMMANDS" != ""; then
-  OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
-fi
-
-AC_MSG_CHECKING("where to install the library")
-OCAMLFIND_DEST_DIR="/public/sacerdot/prova"
-AC_MSG_RESULT($OCAMLFIND_DEST_DIR)
-
-AC_MSG_CHECKING("where to install the META files")
-OCAMLFIND_META_DIR="/public/sacerdot/prova/META"
-AC_MSG_RESULT($OCAMLFIND_META_DIR)
-
-AC_SUBST(OCAMLFIND)
-AC_SUBST(OCAMLFIND_DEST_DIR)
-AC_SUBST(OCAMLFIND_META_DIR)
-AC_SUBST(CHOSEN_TERM_EDITOR)
-AC_SUBST(CHOSEN_TERM_PARSER)
-AC_SUBST(CHOSEN_TRANSFORMER)
-
-AC_OUTPUT([
-  Makefile
-  Makefile.common
-])
-