]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/ocaml/configure.ac
detect and use {ocamlc,ocamlopt}.opt when they are available
[helm.git] / helm / ocaml / configure.ac
index 8f368b0f9eead01a3d4749b695a3bb16aa5f5c8a..0651685f151b9089604c0e2ec9c671946ca961ae 100644 (file)
@@ -8,6 +8,29 @@ fi
 AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
 if test $HAVE_OCAMLFIND = "no"; then
   AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
+else
+  OCAMLFIND=ocamlfind
+fi
+
+OCAMLFIND_COMMANDS=""
+AC_CHECK_PROG(HAVE_OCAMLC_OPT, ocamlc.opt, yes, no)
+if test $HAVE_OCAMLC_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlc=ocamlc.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlc=ocamlc.opt"
+  fi
+fi
+AC_CHECK_PROG(HAVE_OCAMLOPT_OPT, ocamlopt.opt, yes, no)
+if test $HAVE_OCAMLOPT_OPT = "yes"; then
+  if test "$OCAMLFIND_COMMANDS" = ""; then
+    OCAMLFIND_COMMANDS="ocamlopt=ocamlopt.opt"
+  else
+    OCAMLFIND_COMMANDS="$OCAMLFIND_COMMANDS ocamlopt=ocamlopt.opt"
+  fi
+fi
+if test "$OCAMLFIND_COMMANDS" != ""; then
+  OCAMLFIND="OCAMLFIND_COMMANDS='$OCAMLFIND_COMMANDS' $OCAMLFIND"
 fi
 
 AC_MSG_CHECKING("where to install the library")
@@ -18,6 +41,7 @@ AC_MSG_CHECKING("where to install the META files")
 OCAMLFIND_META_DIR="/public/sacerdot/prova/META"
 AC_MSG_RESULT($OCAMLFIND_META_DIR)
 
+AC_SUBST(OCAMLFIND)
 AC_SUBST(OCAMLFIND_DEST_DIR)
 AC_SUBST(OCAMLFIND_META_DIR)
 AC_SUBST(CHOSEN_TERM_EDITOR)