]> matita.cs.unibo.it Git - helm.git/blobdiff - matita/configure.ac
Update online helper entries
[helm.git] / matita / configure.ac
index 36f787c66b7e7e3ccb096dd46532ba1f8dfb0634..04b7da8bdaf2fd1da221d42bca31b30539fe4bcb 100644 (file)
@@ -5,7 +5,7 @@ AC_INIT(matita/matitaTypes.ml)
 DEBUG_DEFAULT="true"
 DEFAULT_DBHOST="mysql://mowgli.cs.unibo.it"
 RT_BASE_DIR_DEFAULT="`pwd`/matita"
-MATITA_VERSION="0.99.3"
+MATITA_VERSION="0.99.4"
 DISTRIBUTED="yes"  # "yes" for distributed tarballs
 # End of distribution settings
 
@@ -24,11 +24,11 @@ if test $HAVE_OCAMLFIND = "yes"; then
 else
   AC_MSG_ERROR(could not find ocamlfind)
 fi
-AC_CHECK_PROG(HAVE_LABLGLADECC, lablgladecc, yes, no)
+AC_CHECK_PROG(HAVE_LABLGLADECC, lablgladecc3, yes, no)
 if test $HAVE_LABLGLADECC = "yes"; then
-  LABLGLADECC="lablgladecc"
+  LABLGLADECC="lablgladecc3"
 else
-  AC_MSG_ERROR(could not find lablgladecc)
+  AC_MSG_ERROR(could not find lablgladecc3)
 fi
 AC_CHECK_PROG(HAVE_CAMLP5O, camlp5o, yes, no)
 if test $HAVE_CAMLP5O = "yes"; then
@@ -63,8 +63,11 @@ echo "done"
 FINDLIB_LIBSREQUIRES="\
 expat \
 http \
+pcre \
+str \
+unix \
 lablgtk3 \
-lablgtk3.sourceview3 \
+lablgtk3-sourceview3 \
 netstring \
 ulex-camlp5 \
 zip \
@@ -89,7 +92,7 @@ $FINDLIB_COMREQUIRES \
 "
 FINDLIB_REQUIRES="\
 $FINDLIB_CREQUIRES \
-lablgtk3.sourceview3 \
+lablgtk3-sourceview3 \
 "
 
 for r in $FINDLIB_LIBSREQUIRES $FINDLIB_REQUIRES