]> matita.cs.unibo.it Git - helm.git/blob - DEVEL/lablgtkmathview/0.7.3-1/debian/rules
[svn-buildpackage] Tagging lablgtkmathview (0.7.3-1)
[helm.git] / DEVEL / lablgtkmathview / 0.7.3-1 / debian / rules
1 #!/usr/bin/make -f
2 include /usr/share/cdbs/1/rules/debhelper.mk
3 include /usr/share/cdbs/1/class/autotools.mk
4
5 PKGNAME = liblablgtkmathview-ocaml-dev
6
7 OCAMLABI := $(shell ocamlc -version)
8 OCAMLLIBDIR := $(shell ocamlc -where)
9 OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
10 HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
11 DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
12
13 ocamlinit:
14         for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
15 makebuilddir/$(PKGNAME):: ocamlinit
16
17 DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAMLLIBDIR)