]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/gdome_xslt/debian/rules
added debian stuff and a makefile with "dist" target
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=3
10
11 TARGETDIR = debian/libgdome2-xslt-ocaml-dev
12
13 configure: configure-stamp
14 configure-stamp:
15         dh_testdir
16
17         cd ocaml/gdome_xslt/; ./configure
18         touch configure-stamp
19
20
21 build: build-stamp
22
23 build-stamp: configure-stamp 
24         dh_testdir
25
26         $(MAKE) -C C/gdome_xslt/
27         $(MAKE) -C ocaml/gdome_xslt/
28         -if [ -x /usr/bin/ocamlopt ]; then \
29                 $(MAKE) -C ocaml/gdome_xslt/ opt; \
30         fi
31
32         touch build-stamp
33
34 clean:
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp configure-stamp
38
39         -$(MAKE) -C ocaml/gdome_xslt/ distclean
40         -$(MAKE) -C C/gdome_xslt/ clean
41
42         dh_clean
43
44 install: build
45         dh_testdir
46         dh_testroot
47         dh_clean -k
48         dh_installdirs -s
49
50     # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
51         # official /var/lib/ocaml/ld.conf
52         CAMLLIB=$(CURDIR) $(MAKE) -C ocaml/gdome_xslt/ install PREFIX=$(CURDIR)/$(TARGETDIR)/usr/lib/ocaml
53
54 movefiles: install
55         dh_movefiles -p libgdome2-xslt-ocaml --sourcedir=$(TARGETDIR)
56
57 # Build architecture-dependent files here.
58 binary-arch: build movefiles
59         dh_testdir
60         dh_testroot
61         dh_installdocs -s
62         dh_installexamples -s
63         dh_installman -s
64         dh_installinfo -s
65         dh_installchangelogs -s
66         dh_link -s
67         dh_strip -s
68         dh_compress -s
69         dh_ocamlld -p libgdome2-xslt-ocaml /usr/lib/ocaml/gdome2-xslt
70         dh_fixperms -s
71         dh_installdeb -s
72         dh_shlibdeps -s
73         dh_gencontrol -s
74         dh_md5sums -s
75         dh_builddeb -s
76
77 binary: binary-arch
78 .PHONY: build clean movefiles binary-arch binary install configure