]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/lablgtkmathview/debian/rules
Initial revision
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=4
10
11 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
12
13 configure: configure-stamp
14 configure-stamp:
15         dh_testdir
16         # Add here commands to configure the package.
17         ./configure
18
19         touch configure-stamp
20
21 build: configure-stamp build-stamp
22 build-stamp:
23         dh_testdir
24
25         # Add here commands to compile the package.
26         $(MAKE)
27         -test -x /usr/bin/ocamlopt && $(MAKE) opt
28
29         touch build-stamp
30
31 clean:
32         dh_testdir
33         dh_testroot
34         rm -f build-stamp configure-stamp
35
36         # Add here commands to clean up after the build process.
37         -$(MAKE) distclean
38
39         dh_clean
40
41 install: build
42         dh_testdir
43         dh_testroot
44         dh_clean -k
45         dh_installdirs -s
46
47         # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
48         # official /var/lib/ocaml/ld.conf
49         $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml
50
51 movefiles: install
52         dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
53
54 # Build architecture-independent files here.
55 binary-indep: build movefiles
56 # We have nothing to do by default.
57
58 # Build architecture-dependent files here.
59 binary-arch: build install
60         dh_testdir
61         dh_testroot
62         dh_installdocs -s
63         dh_installexamples -s
64         dh_installmanpages -s
65         dh_installinfo -s
66 #       dh_undocumented
67         dh_installchangelogs -s ChangeLog
68         dh_link -s
69         dh_strip -s
70         dh_compress -s
71 #       dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
72         dh_fixperms -s
73         dh_installdeb -s
74         dh_shlibdeps -s
75         dh_gencontrol -s
76         dh_md5sums -s
77         dh_builddeb -s
78
79 binary: binary-indep binary-arch
80 .PHONY: build clean binary-indep binary-arch binary install configure