]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/lablgtkmathview/debian/rules
8b6ed0bb5febbb844e6584e1398737d5d8852283
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
9 OCAML_STDLIB_DIR = $(shell ocamlc -where)
10
11 configure: configure-stamp
12 configure-stamp:
13         dh_testdir
14         ./configure
15
16         touch configure-stamp
17
18 build: configure-stamp build-stamp
19 build-stamp:
20         dh_testdir
21
22         $(MAKE)
23         if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
24
25         touch build-stamp
26
27 clean:
28         dh_testdir
29         dh_testroot
30         rm -f build-stamp configure-stamp
31
32         -$(MAKE) distclean
33
34         dh_clean
35 distclean: clean
36
37 install: build
38         dh_testdir
39         dh_testroot
40         dh_clean -k
41         dh_installdirs -s
42
43         $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
44
45 movefiles: install
46         dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
47
48 binary-arch: build install
49         dh_testdir
50         dh_testroot
51         dh_installdocs -s
52         dh_installexamples -s
53         dh_installmanpages -s
54         dh_installinfo -s
55         dh_installchangelogs -s ChangeLog
56         dh_link -s
57         dh_strip -s
58         dh_compress -s
59         dh_fixperms -s
60         dh_installdeb -s
61         dh_shlibdeps -s
62         dh_gencontrol -s
63         dh_md5sums -s
64         dh_builddeb -s
65
66 binary: binary-arch
67 .PHONY: build clean binary-arch binary install configure