]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/lablgtkmathview/debian/rules
Synced debian dir.
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 configure: configure-stamp
12 configure-stamp:
13         dh_testdir
14         # Add here commands to configure the package.
15         ./configure
16
17         touch configure-stamp
18
19 build: configure-stamp build-stamp
20 build-stamp:
21         dh_testdir
22
23         # Add here commands to compile the package.
24         $(MAKE)
25         -$(MAKE) opt
26         #/usr/bin/docbook-to-man debian/lablgtkmathview.sgml > lablgtkmathview.1
27
28         touch build-stamp
29
30 clean:
31         dh_testdir
32         dh_testroot
33         rm -f build-stamp configure-stamp
34
35         # Add here commands to clean up after the build process.
36         -$(MAKE) distclean
37
38         dh_clean
39
40 install: build
41         dh_testdir
42         dh_testroot
43         dh_clean -k
44         dh_installdirs
45
46         # Add here commands to install the package into debian/lablgtkmathview.
47         $(MAKE) install DESTDIR=$(CURDIR)/debian/lablgtkmathview/usr/lib/ocaml
48
49
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
53
54 # Build architecture-dependent files here.
55 binary-arch: build install
56         dh_testdir
57         dh_testroot
58 #       dh_installdebconf       
59         dh_installdocs
60         dh_installexamples
61         dh_installmenu
62 #       dh_installlogrotate
63 #       dh_installemacsen
64 #       dh_installpam
65 #       dh_installmime
66 #       dh_installinit
67         dh_installcron
68         dh_installmanpages
69         dh_installinfo
70 #       dh_undocumented
71         dh_installchangelogs ChangeLog
72         dh_link
73         dh_strip
74         dh_compress
75         dh_fixperms
76 #       dh_makeshlibs
77         dh_installdeb
78 #       dh_perl
79         dh_shlibdeps
80         dh_gencontrol
81         dh_md5sums
82         dh_builddeb
83
84 binary: binary-indep binary-arch
85 .PHONY: build clean binary-indep binary-arch binary install configure