]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/lablgtkmathview/debian/rules
debian package for ocaml 3.07
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
9 OCAML_STDLIB_DIR = $(shell ocamlc -where)
10
11 include debian/autodebian.make
12
13 configure: configure-stamp
14 configure-stamp: autodebian-stamp
15         dh_testdir
16         ./configure
17
18         touch configure-stamp
19
20 build: configure-stamp build-stamp
21 build-stamp:
22         dh_testdir
23
24         $(MAKE)
25         if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
26
27         touch build-stamp
28
29 clean: autodebian-clean
30         dh_testdir
31         dh_testroot
32         rm -f build-stamp configure-stamp
33
34         -$(MAKE) distclean
35
36         dh_clean
37 distclean: clean autodebian-distclean
38
39 install: build
40         dh_testdir
41         dh_testroot
42         dh_clean -k
43         dh_installdirs -s
44
45         $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
46
47 movefiles: install
48         dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
49
50 binary-arch: build install
51         dh_testdir
52         dh_testroot
53         dh_installdocs -s
54         dh_installexamples -s
55         dh_installmanpages -s
56         dh_installinfo -s
57         dh_installchangelogs -s ChangeLog
58         dh_link -s
59         dh_strip -s
60         dh_compress -s
61         dh_fixperms -s
62         dh_installdeb -s
63         dh_shlibdeps -s
64         dh_gencontrol -s
65         dh_md5sums -s
66         dh_builddeb -s
67
68 binary: binary-arch
69 .PHONY: build clean binary-arch binary install configure