]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/lablgtksourceview/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / lablgtksourceview / debian / rules
1 #!/usr/bin/make -f
2 include /usr/share/cdbs/1/rules/debhelper.mk
3 include /usr/share/cdbs/1/class/autotools.mk
4
5 OCAMLABI := $(shell ocamlc -version)
6 OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
7 DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
8
9 ocamlinit:
10         for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done