]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/mathml_editor/debian/rules
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / mathml_editor / debian / rules
1 #!/usr/bin/make -f
2
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
5
6 export DH_COMPAT=4
7
8 # These are used for cross-compiling and for saving the configure script
9 # from having to guess our platform (since we know it already)
10 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
13 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
14         CFLAGS += -O0
15 else
16         CFLAGS += -O2
17 endif
18 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
19         INSTALL_PROGRAM += -s
20 endif
21
22 config.status: configure
23         dh_testdir
24         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
25
26 build: build-stamp
27 build-stamp:  config.status
28         dh_testdir
29
30         $(MAKE)
31
32         touch build-stamp
33
34 clean:
35         dh_testdir
36         dh_testroot
37         rm -f build-stamp 
38
39         -$(MAKE) distclean
40 # ifneq "$(wildcard /usr/share/misc/config.sub)" ""
41 #       cp -f /usr/share/misc/config.sub config.sub
42 # endif
43 # ifneq "$(wildcard /usr/share/misc/config.guess)" ""
44 #       cp -f /usr/share/misc/config.guess config.guess
45 # endif
46
47         dh_clean
48
49 install: build
50         dh_testdir
51         dh_testroot
52         dh_clean -k
53         dh_installdirs
54         $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
55         dh_movefiles
56
57 binary-arch: build install
58         dh_testdir -s
59         dh_testroot -s
60         dh_installchangelogs -s ChangeLog
61         dh_installdocs -s
62 #       dh_installexamples -s
63 #       dh_installinfo -s
64         dh_link -s
65         dh_strip -s
66         dh_compress -s
67         dh_fixperms -s
68         dh_makeshlibs -p libeditex0
69         dh_installdeb -s
70         dh_shlibdeps -s
71         dh_gencontrol -s
72         dh_md5sums -s
73         dh_builddeb -s
74
75 binary: binary-arch
76 .PHONY: build clean binary-arch binary install