]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/mlminidom/debian/rules
Initial revision
[helm.git] / helm / DEVEL / mlminidom / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 UPSTREAM_CHANGELOG = ChangeLog
12
13 configure: configure-stamp
14 configure-stamp:
15         dh_testdir
16         # Add here commands to configure the package.
17         ./configure
18
19         touch configure-stamp
20
21 build: configure-stamp build-stamp
22 build-stamp:
23         dh_testdir
24
25         # Add here commands to compile the package.
26         $(MAKE)
27         -test -x /usr/bin/ocamlopt && $(MAKE) opt
28         #/usr/bin/docbook-to-man debian/mlminidom.sgml > mlminidom.1
29
30         touch build-stamp
31
32 clean:
33         dh_testdir
34         dh_testroot
35         rm -f build-stamp configure-stamp
36
37         # Add here commands to clean up after the build process.
38         -$(MAKE) distclean
39
40         dh_clean
41
42 install: build
43         dh_testdir
44         dh_testroot
45         dh_clean -k
46         dh_installdirs
47
48         # Add here commands to install the package into debian/mlminidom.
49         $(MAKE) install DESTDIR=$(CURDIR)/debian/mlminidom/usr/lib/ocaml
50
51
52 # Build architecture-independent files here.
53 binary-indep: build install
54 # We have nothing to do by default.
55
56 # Build architecture-dependent files here.
57 binary-arch: build install
58         dh_testdir
59         dh_testroot
60 #       dh_installdebconf       
61         dh_installdocs
62         dh_installexamples
63 #       dh_installmenu
64 #       dh_installlogrotate
65 #       dh_installemacsen
66 #       dh_installpam
67 #       dh_installmime
68 #       dh_installinit
69 #       dh_installcron
70 #       dh_installmanpages
71 #       dh_installinfo
72 #       dh_undocumented
73         if [ -s $(UPSTREAM_CHANGELOG) ]; then \
74                 dh_installchangelogs $(UPSTREAM_CHANGELOG); \
75         else \
76                 dh_installchangelogs; \
77         fi
78         dh_link
79         dh_strip
80         dh_compress
81         dh_fixperms
82 #       dh_makeshlibs
83         dh_installdeb
84 #       dh_perl
85         dh_shlibdeps
86         dh_gencontrol
87         dh_md5sums
88         dh_builddeb
89
90 binary: binary-indep binary-arch
91 .PHONY: build clean binary-indep binary-arch binary install configure