]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/changelog
ocaml 3.09 transition
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
1 ocaml-http (0.1.2-1) unstable; urgency=low
2
3   * avoid exceptions for closing connection twice during finaliztion of
4     connection objects (thanks to Eric Strokes <eric.stokes@csun.edu>
5     for the patch)
6
7  -- Stefano Zacchiroli <zack@debian.org>  Wed, 14 Sep 2005 18:03:40 +0200
8
9 ocaml-http (0.1.1-1) unstable; urgency=low
10
11   * added ?default parameter to "param" method
12   * fixed bug in response status line parsing
13   * integrated patch for HTTP/1.1 persistent connections from
14     Eric Cooper <ecc@cmu.edu>:
15     - added support for persistent connections to http_daemon.ml: server
16       now loops until End_of_file (or any exception) occurs when trying
17       to parse the next request
18   * debian/control
19     - bumped pcre and ocamlnet dependencies
20     - bumped standards-version to 3.6.2
21
22  -- Stefano Zacchiroli <zack@debian.org>  Wed, 16 Mar 2005 09:24:07 +0100
23
24 ocaml-http (0.1.0-2) unstable; urgency=low
25
26   * rebuilt against ocaml 3.08.3
27
28  -- Stefano Zacchiroli <zack@debian.org>  Tue, 29 Mar 2005 11:39:24 +0200
29
30 ocaml-http (0.1.0-1) unstable; urgency=low
31
32   * first debian official package
33
34  -- Stefano Zacchiroli <zack@debian.org>  Tue,  8 Feb 2005 22:45:54 +0100
35
36 ocaml-http (0.1.0) unstable; urgency=low
37
38   * added "daemon specifications": a unified way of specifying daemons
39     behaviour including old parameters of Http_daemon.start together
40     with authentication requirements and exception handling
41   * added new way of building daemons starting from specifications, old
42     ways (e.g. Http_daemon.start) are now deprecated
43   * added sigpipe handling to avoid daemons dying for uncaught signals
44   * added exception handler (as part of a daemon specification), it can
45     be used to ensure that some code is execute before a process/thread
46     die for uncaught exception (e.g. unlocking a global mutex)
47   * added authentication requirements (as part of a daemon
48     specification): an handy way to specify required user name and
49     password for HTTP basic authentication
50   * added head_callback to Http_user_agent in order to have access to
51     response status and headers in HTTP requests
52   * changed license from GPL to LGPL
53   * improved ocamldoc documentation and debian packaging
54
55  -- Stefano Zacchiroli <zack@debian.org>  Thu,  3 Feb 2005 23:08:14 +0100
56
57 ocaml-http (0.0.10) unstable; urgency=low
58
59   * renamed Http_client module to Http_user_agent to avoid compatibility
60     issues with Netclient. Renamed that module functions removing
61     "http_" prefix (e.g., summarizing, Http_client.http_get ->
62     Http_user_agent.get)
63   * ported to ocaml 3.08
64   * debian/control
65     - bumped standards version to 3.6.1.1
66     - changed deps to ocaml 3.08 and -nox
67
68  -- Stefano Zacchiroli <zack@debian.org>  Thu,  5 Aug 2004 15:06:49 +0200
69
70 ocaml-http (0.0.9) unstable; urgency=low
71
72   * Added support for HTTP Basic authentication
73   * Restyled Http_daemon API so that correct invocations of them are
74     statically typechecked
75   * Added support for HEAD requests to Http_client
76   * ~addr parameter now support not only ip addresses but also hostnames
77   * debian/control
78     - bumped Standards-Version to 3.6.1.0
79   * debian/rules
80     - moved debhelper compatibility level to debian/compat
81
82  -- Stefano Zacchiroli <zack@debian.org>  Tue, 16 Dec 2003 18:01:41 +0100
83
84 ocaml-http (0.0.8) unstable; urgency=low
85
86   * Added support for "ancient" HTTP requests which specify no HTTP
87     version
88     - 'version' method on message now has type 'version option'
89   * Http_daemon now use debugging prints from Http_common like other
90     modules
91   * Added debugging print of requests parse error
92   * Shutdown server socket on abnormal exit (actually: uncaught
93     exceptions or SIGTERM received)
94   * Added a lot of ocamldoc documentation
95   * Added minimal HTTP 1.0/1.1 client support
96
97  -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
98
99 ocaml-http (0.0.7) unstable; urgency=low
100
101   * Added support for POST requests
102   * Implemented a commont 'message' class from which 'request' and
103     'response' inherit
104   * Changed constructor of 'request' objects, requests are now buildable
105     directly (and only) from an input channel
106   * Added client IP address information to Http_request.request class
107   * Added OO daemon interfaces ("daemon" and "connection" classes)
108   * Use Pcre to perform sanity test on headers instead of home made
109     parsing
110   * Callback functions can raise Http_types.Quit to have main daemon
111     quit
112   * Case-insensitive handling of header names
113
114  -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
115
116 ocaml-http (0.0.6) unstable; urgency=low
117
118   * Ship multithreaded and non multithreaded cm{x,}aS
119   * Added support for multiple binding of the same parameter in request
120     objects (new method 'paramAll')
121   * Added support for 'empty' bindings in query arguments (e.g.
122     "/foo?b=" or "/foo?b")
123   * Added some sanity checks
124   * Bumped Standards-Version to 3.5.8
125   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
126   * Added 'Provides libhttp-ocaml-dev-<version>'
127   * Removed GPL from debian/copyright, added reference to
128     /usr/share/common-licenses/GPL
129
130  -- Stefano Zacchiroli <zack@debian.org>  Mon, 25 Nov 2002 11:04:49 +0100
131
132 ocaml-http (0.0.5) unstable; urgency=low
133
134   * Fixed bug for HTTP encoded GET parameters which contain '?' or '&'
135     characters
136   * Added support for chdir in a given document root before starting
137   * Added support for multi threaded daemons
138   * Added a generic 'Http_daemon.respond' function
139   * Added 'toString' method to response objects
140
141  -- Stefano Zacchiroli <zack@debian.org>  Fri, 22 Nov 2002 11:29:37 +0100
142
143 ocaml-http (0.0.3) unstable; urgency=low
144
145   * First release.
146
147  -- Stefano Zacchiroli <zack@debian.org>  Sun, 17 Nov 2002 17:41:41 +0100