]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/changelog
mention sockets' shutdown
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
1 ocaml-http (0.0.8) unstable; urgency=low
2
3   * Added support for "ancient" HTTP requests which specify no HTTP
4     version
5     - 'version' method on message now has type 'version option'
6   * Http_daemon now use debugging prints from Http_common like other
7     modules
8   * Added debugging print of requests parse error
9   * Shutdown server socket on abnormal exit (actually: uncaught
10     exceptions or SIGTERM received)
11
12  -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
13
14 ocaml-http (0.0.7) unstable; urgency=low
15
16   * Added support for POST requests
17   * Implemented a commont 'message' class from which 'request' and
18     'response' inherit
19   * Changed constructor of 'request' objects, requests are now buildable
20     directly (and only) from an input channel
21   * Added client IP address information to Http_request.request class
22   * Added OO daemon interfaces ("daemon" and "connection" classes)
23   * Use Pcre to perform sanity test on headers instead of home made
24     parsing
25   * Callback functions can raise Http_types.Quit to have main daemon
26     quit
27   * Case-insensitive handling of header names
28
29  -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
30
31 ocaml-http (0.0.6) unstable; urgency=low
32
33   * Ship multithreaded and non multithreaded cm{x,}aS
34   * Added support for multiple binding of the same parameter in request
35     objects (new method 'paramAll')
36   * Added support for 'empty' bindings in query arguments (e.g.
37     "/foo?b=" or "/foo?b")
38   * Added some sanity checks
39   * Bumped Standards-Version to 3.5.8
40   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
41   * Added 'Provides libhttp-ocaml-dev-<version>'
42   * Removed GPL from debian/copyright, added reference to
43     /usr/share/common-licenses/GPL
44
45  -- Stefano Zacchiroli <zack@debian.org>  Mon, 25 Nov 2002 11:04:49 +0100
46
47 ocaml-http (0.0.5) unstable; urgency=low
48
49   * Fixed bug for HTTP encoded GET parameters which contain '?' or '&'
50     characters
51   * Added support for chdir in a given document root before starting
52   * Added support for multi threaded daemons
53   * Added a generic 'Http_daemon.respond' function
54   * Added 'toString' method to response objects
55
56  -- Stefano Zacchiroli <zack@debian.org>  Fri, 22 Nov 2002 11:29:37 +0100
57
58 ocaml-http (0.0.3) unstable; urgency=low
59
60   * First release.
61
62  -- Stefano Zacchiroli <zack@debian.org>  Sun, 17 Nov 2002 17:41:41 +0100