]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/changelog
ported to ocaml 3.07
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
1 ocaml-http (0.0.8) unstable; urgency=low
2
3   * Added support for "ancient" HTTP requests which specify no HTTP
4     version
5     - 'version' method on message now has type 'version option'
6   * Http_daemon now use debugging prints from Http_common like other
7     modules
8   * Added debugging print of requests parse error
9   * Shutdown server socket on abnormal exit (actually: uncaught
10     exceptions or SIGTERM received)
11   * Added a lot of ocamldoc documentation
12   * Added minimal HTTP 1.0/1.1 client support
13
14  -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
15
16 ocaml-http (0.0.7) unstable; urgency=low
17
18   * Added support for POST requests
19   * Implemented a commont 'message' class from which 'request' and
20     'response' inherit
21   * Changed constructor of 'request' objects, requests are now buildable
22     directly (and only) from an input channel
23   * Added client IP address information to Http_request.request class
24   * Added OO daemon interfaces ("daemon" and "connection" classes)
25   * Use Pcre to perform sanity test on headers instead of home made
26     parsing
27   * Callback functions can raise Http_types.Quit to have main daemon
28     quit
29   * Case-insensitive handling of header names
30
31  -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
32
33 ocaml-http (0.0.6) unstable; urgency=low
34
35   * Ship multithreaded and non multithreaded cm{x,}aS
36   * Added support for multiple binding of the same parameter in request
37     objects (new method 'paramAll')
38   * Added support for 'empty' bindings in query arguments (e.g.
39     "/foo?b=" or "/foo?b")
40   * Added some sanity checks
41   * Bumped Standards-Version to 3.5.8
42   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
43   * Added 'Provides libhttp-ocaml-dev-<version>'
44   * Removed GPL from debian/copyright, added reference to
45     /usr/share/common-licenses/GPL
46
47  -- Stefano Zacchiroli <zack@debian.org>  Mon, 25 Nov 2002 11:04:49 +0100
48
49 ocaml-http (0.0.5) unstable; urgency=low
50
51   * Fixed bug for HTTP encoded GET parameters which contain '?' or '&'
52     characters
53   * Added support for chdir in a given document root before starting
54   * Added support for multi threaded daemons
55   * Added a generic 'Http_daemon.respond' function
56   * Added 'toString' method to response objects
57
58  -- Stefano Zacchiroli <zack@debian.org>  Fri, 22 Nov 2002 11:29:37 +0100
59
60 ocaml-http (0.0.3) unstable; urgency=low
61
62   * First release.
63
64  -- Stefano Zacchiroli <zack@debian.org>  Sun, 17 Nov 2002 17:41:41 +0100