]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/changelog
target 0.1.0 changelog (not yet released ...)
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
1 ocaml-http (0.1.0) unstable; urgency=low
2
3   * added "daemon specifications": a unified way of specifying daemons
4     behaviour including old parameters of Http_daemon.start together
5     with authentication requirements and exception handling
6   * added new way of building daemons starting from specifications, old
7     ways (e.g. Http_daemon.start) are now deprecated
8   * added sigpipe handling to avoid daemons dying for uncaught signals
9   * added exception handler (as part of a daemon specification), it can
10     be used to ensure that some code is execute before a process/thread
11     die for uncaught exception (e.g. unlocking a global mutex)
12   * added authentication requirements (as part of a daemon
13     specification): an handy way to specify required user name and
14     password for HTTP basic authentication
15   * added head_callback to Http_user_agent in order to have access to
16     response status and headers in HTTP requests
17
18  -- Stefano Zacchiroli <zack@debian.org>  Thu,  3 Feb 2005 23:08:14 +0100
19
20 ocaml-http (0.0.10) unstable; urgency=low
21
22   * renamed Http_client module to Http_user_agent to avoid compatibility
23     issues with Netclient. Renamed that module functions removing
24     "http_" prefix (e.g., summarizing, Http_client.http_get ->
25     Http_user_agent.get)
26   * ported to ocaml 3.08
27   * debian/control
28     - bumped standards version to 3.6.1.1
29     - changed deps to ocaml 3.08 and -nox
30
31  -- Stefano Zacchiroli <zack@debian.org>  Thu,  5 Aug 2004 15:06:49 +0200
32
33 ocaml-http (0.0.9) unstable; urgency=low
34
35   * Added support for HTTP Basic authentication
36   * Restyled Http_daemon API so that correct invocations of them are
37     statically typechecked
38   * Added support for HEAD requests to Http_client
39   * ~addr parameter now support not only ip addresses but also hostnames
40   * debian/control
41     - bumped Standards-Version to 3.6.1.0
42   * debian/rules
43     - moved debhelper compatibility level to debian/compat
44
45  -- Stefano Zacchiroli <zack@debian.org>  Tue, 16 Dec 2003 18:01:41 +0100
46
47 ocaml-http (0.0.8) unstable; urgency=low
48
49   * Added support for "ancient" HTTP requests which specify no HTTP
50     version
51     - 'version' method on message now has type 'version option'
52   * Http_daemon now use debugging prints from Http_common like other
53     modules
54   * Added debugging print of requests parse error
55   * Shutdown server socket on abnormal exit (actually: uncaught
56     exceptions or SIGTERM received)
57   * Added a lot of ocamldoc documentation
58   * Added minimal HTTP 1.0/1.1 client support
59
60  -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
61
62 ocaml-http (0.0.7) unstable; urgency=low
63
64   * Added support for POST requests
65   * Implemented a commont 'message' class from which 'request' and
66     'response' inherit
67   * Changed constructor of 'request' objects, requests are now buildable
68     directly (and only) from an input channel
69   * Added client IP address information to Http_request.request class
70   * Added OO daemon interfaces ("daemon" and "connection" classes)
71   * Use Pcre to perform sanity test on headers instead of home made
72     parsing
73   * Callback functions can raise Http_types.Quit to have main daemon
74     quit
75   * Case-insensitive handling of header names
76
77  -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
78
79 ocaml-http (0.0.6) unstable; urgency=low
80
81   * Ship multithreaded and non multithreaded cm{x,}aS
82   * Added support for multiple binding of the same parameter in request
83     objects (new method 'paramAll')
84   * Added support for 'empty' bindings in query arguments (e.g.
85     "/foo?b=" or "/foo?b")
86   * Added some sanity checks
87   * Bumped Standards-Version to 3.5.8
88   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
89   * Added 'Provides libhttp-ocaml-dev-<version>'
90   * Removed GPL from debian/copyright, added reference to
91     /usr/share/common-licenses/GPL
92
93  -- Stefano Zacchiroli <zack@debian.org>  Mon, 25 Nov 2002 11:04:49 +0100
94
95 ocaml-http (0.0.5) unstable; urgency=low
96
97   * Fixed bug for HTTP encoded GET parameters which contain '?' or '&'
98     characters
99   * Added support for chdir in a given document root before starting
100   * Added support for multi threaded daemons
101   * Added a generic 'Http_daemon.respond' function
102   * Added 'toString' method to response objects
103
104  -- Stefano Zacchiroli <zack@debian.org>  Fri, 22 Nov 2002 11:29:37 +0100
105
106 ocaml-http (0.0.3) unstable; urgency=low
107
108   * First release.
109
110  -- Stefano Zacchiroli <zack@debian.org>  Sun, 17 Nov 2002 17:41:41 +0100