]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/changelog
debugging print of HTTP request's parsing errors
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
1 ocaml-http (0.0.8) unstable; urgency=low
2
3   * Added support for "ancient" HTTP requests which specify no HTTP
4     version
5     - 'version' method on message now has type 'version option'
6   * Http_daemon now use debugging prints from Http_common like other
7     modules
8   * Added debugging print of requests parse error
9
10  -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
11
12 ocaml-http (0.0.7) unstable; urgency=low
13
14   * Added support for POST requests
15   * Implemented a commont 'message' class from which 'request' and
16     'response' inherit
17   * Changed constructor of 'request' objects, requests are now buildable
18     directly (and only) from an input channel
19   * Added client IP address information to Http_request.request class
20   * Added OO daemon interfaces ("daemon" and "connection" classes)
21   * Use Pcre to perform sanity test on headers instead of home made
22     parsing
23   * Callback functions can raise Http_types.Quit to have main daemon
24     quit
25   * Case-insensitive handling of header names
26
27  -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
28
29 ocaml-http (0.0.6) unstable; urgency=low
30
31   * Ship multithreaded and non multithreaded cm{x,}aS
32   * Added support for multiple binding of the same parameter in request
33     objects (new method 'paramAll')
34   * Added support for 'empty' bindings in query arguments (e.g.
35     "/foo?b=" or "/foo?b")
36   * Added some sanity checks
37   * Bumped Standards-Version to 3.5.8
38   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
39   * Added 'Provides libhttp-ocaml-dev-<version>'
40   * Removed GPL from debian/copyright, added reference to
41     /usr/share/common-licenses/GPL
42
43  -- Stefano Zacchiroli <zack@debian.org>  Mon, 25 Nov 2002 11:04:49 +0100
44
45 ocaml-http (0.0.5) unstable; urgency=low
46
47   * Fixed bug for HTTP encoded GET parameters which contain '?' or '&'
48     characters
49   * Added support for chdir in a given document root before starting
50   * Added support for multi threaded daemons
51   * Added a generic 'Http_daemon.respond' function
52   * Added 'toString' method to response objects
53
54  -- Stefano Zacchiroli <zack@debian.org>  Fri, 22 Nov 2002 11:29:37 +0100
55
56 ocaml-http (0.0.3) unstable; urgency=low
57
58   * First release.
59
60  -- Stefano Zacchiroli <zack@debian.org>  Sun, 17 Nov 2002 17:41:41 +0100