]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/rules
Initial revision
[helm.git] / helm / DEVEL / ocaml-http / debian / rules
1 #!/usr/bin/make -f
2
3 #export DH_VERBOSE=1
4 export DH_COMPAT=4
5
6 TARGETDIR = $(CURDIR)/debian/libhttp-ocaml-dev
7 OCAML_LIB_DIR = $(shell ocamlc -where)
8
9 build: build-stamp
10 build-stamp:
11         dh_testdir
12         $(MAKE) all
13         if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
14         touch build-stamp
15
16 clean:
17         dh_testdir
18         dh_testroot
19         rm -f build-stamp
20         -$(MAKE) distclean
21         dh_clean
22
23 install: build
24         dh_testdir
25         dh_testroot
26         dh_clean -k
27         dh_installdirs
28         $(MAKE) install DESTDIR=$(TARGETDIR)$(OCAML_LIB_DIR)
29         $(MAKE) doc
30
31 binary-arch: build install
32         dh_testdir
33         dh_testroot
34         dh_installdocs
35         dh_installexamples
36         dh_installchangelogs 
37         dh_link
38         dh_strip
39         dh_compress
40         dh_fixperms
41         dh_installdeb
42         dh_shlibdeps
43         dh_gencontrol
44         dh_md5sums
45         dh_builddeb
46
47 binary: binary-arch
48 .PHONY: build clean binary-arch binary install