]> matita.cs.unibo.it Git - helm.git/blob - helm/DEVEL/ocaml-http/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / ocaml-http / debian / rules
1 #!/usr/bin/make -f
2
3 #export DH_VERBOSE=1
4
5 TARGETDIR = $(CURDIR)/debian/libhttp-ocaml-dev
6 OCAML_LIB_DIR = $(shell ocamlc -where)
7
8 build: build-stamp
9 build-stamp:
10         dh_testdir
11         $(MAKE) all
12         if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
13         touch build-stamp
14
15 clean:
16         dh_testdir
17         dh_testroot
18         rm -f build-stamp
19         -$(MAKE) distclean
20         dh_clean
21
22 install: build
23         dh_testdir
24         dh_testroot
25         dh_clean -k
26         dh_installdirs
27         $(MAKE) install DESTDIR=$(TARGETDIR)$(OCAML_LIB_DIR)
28
29 binary-arch: build install
30         dh_testdir
31         dh_testroot
32         dh_installdocs
33         dh_installexamples
34         dh_installchangelogs 
35         dh_link
36         dh_strip
37         dh_compress
38         dh_fixperms
39         dh_installdeb
40         dh_shlibdeps
41         dh_gencontrol
42         dh_md5sums
43         dh_builddeb
44
45 binary: binary-arch
46 .PHONY: build clean binary-arch binary install