]> matita.cs.unibo.it Git - helm.git/blob - helm/helmpot/debian/rules
ocaml 3.09 transition
[helm.git] / helm / helmpot / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 build: build-stamp
12 build-stamp:
13         dh_testdir
14
15         ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
16         # Add here commands to compile the package.
17         $(MAKE)
18
19         touch build-stamp
20
21 clean:
22         dh_testdir
23         dh_testroot
24         rm -f build-stamp
25
26         # Add here commands to clean up after the build process.
27         -$(MAKE) distclean
28
29         dh_clean
30
31 install: build
32         dh_testdir
33         dh_testroot
34         dh_clean -k
35         dh_installdirs
36
37         # Add here commands to install the package into debian/tmp.
38         $(MAKE) install prefix=$(CURDIR)/debian/helmpot/usr
39
40
41 # Build architecture-independent files here.
42 binary-indep: build install
43 # We have nothing to do by default.
44
45 # Build architecture-dependent files here.
46 binary-arch: build install
47         dh_testdir
48         dh_testroot
49 #       dh_installdebconf       
50         dh_installdocs
51 #       dh_installexamples
52 #       dh_installmenu
53 #       dh_installemacsen
54 #       dh_installpam
55 #       dh_installinit
56 #       dh_installcron
57 #       dh_installmanpages
58         dh_installinfo
59         dh_undocumented
60         dh_installchangelogs ChangeLog
61         dh_link
62         dh_strip
63         dh_compress
64         dh_fixperms
65         # You may want to make some executables suid here.
66 #       dh_makeshlibs
67         dh_installdeb
68 #       dh_perl
69         dh_shlibdeps
70         dh_gencontrol
71         dh_md5sums
72         dh_builddeb
73
74 binary: binary-indep binary-arch
75 .PHONY: build clean binary-indep binary-arch binary install