]> matita.cs.unibo.it Git - helm.git/blob - helm/minidom/debian/rules
ocaml 3.09 transition
[helm.git] / helm / minidom / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 # shared library versions, option 1
12 #version=0.1.0
13 #major=0
14 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
15 version=`ls src/.libs/lib*.so.* | \
16         awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
17 major=`ls src/.libs/lib*.so.* | \
18         awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
19
20 configure: configure-stamp
21 configure-stamp:
22         dh_testdir
23         # Add here commands to configure the package.
24         ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
25
26         touch configure-stamp
27
28 build: configure-stamp build-stamp
29 build-stamp:
30         dh_testdir
31
32         # Add here commands to compile the package.
33         $(MAKE)
34
35         touch build-stamp
36
37 clean:
38         dh_testdir
39         dh_testroot
40         rm -f build-stamp configure-stamp
41
42         # Add here commands to clean up after the build process.
43         -$(MAKE) distclean
44
45         dh_clean
46
47 install: build
48         dh_testdir
49         dh_testroot
50         dh_clean -k
51         dh_installdirs
52
53         # Add here commands to install the package into debian/minidom.
54         $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
55
56
57 # Build architecture-independent files here.
58 binary-indep: build install
59 # We have nothing to do by default.
60
61 # Build architecture-dependent files here.
62 binary-arch: build install
63         dh_testdir
64         dh_testroot
65         #
66         # build libminidom${major} package by moving files from minidom-dev
67         #
68 #       dh_movefiles -plibminidom$(major)             \
69 #       usr/lib/libminidom.so.$(major)        \
70 #       usr/lib/libminidom.so.$(version)
71 #       dh_movefiles get file contents from debian/*.files
72         dh_movefiles
73
74 #       dh_installdebconf       
75         dh_installdocs
76         dh_installexamples
77         dh_installmenu
78 #       dh_installemacsen
79 #       dh_installpam
80 #       dh_installinit
81         dh_installcron
82         dh_installmanpages
83         dh_installinfo
84         dh_undocumented
85         dh_installchangelogs ChangeLog
86         dh_link
87         dh_strip
88         dh_compress
89         dh_fixperms
90         # You may want to make some executables suid here.
91 #       dh_suidregister
92         dh_makeshlibs
93         dh_installdeb
94 #       dh_perl
95         dh_shlibdeps
96         dh_gencontrol
97         dh_md5sums
98         dh_builddeb
99
100 binary: binary-indep binary-arch
101 .PHONY: build clean binary-indep binary-arch binary install configure