]> matita.cs.unibo.it Git - helm.git/blob - helm/minidom/debian/rules
Added debian dir for debian packaging
[helm.git] / helm / minidom / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 # shared library versions, option 1
12 #version=0.1.0
13 #major=0
14 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
15 version=`ls src/.libs/lib*.so.* | \
16         awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
17 major=`ls src/.libs/lib*.so.* | \
18         awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
19
20 configure: configure-stamp
21 configure-stamp:
22         dh_testdir
23         # Add here commands to configure the package.
24         ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
25
26         touch configure-stamp
27
28 build: configure-stamp build-stamp
29 build-stamp:
30         dh_testdir
31
32         # Add here commands to compile the package.
33         $(MAKE)
34
35         touch build-stamp
36
37 clean:
38         dh_testdir
39         dh_testroot
40         rm -f build-stamp configure-stamp
41
42         # Add here commands to clean up after the build process.
43         -$(MAKE) distclean
44
45         dh_clean
46
47 install: build
48         dh_testdir
49         dh_testroot
50         dh_clean -k
51         dh_installdirs
52
53         # Add here commands to install the package into debian/minidom.
54         $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
55
56
57 # Build architecture-independent files here.
58 binary-indep: build install
59 # We have nothing to do by default.
60
61 # Build architecture-dependent files here.
62 binary-arch: build install
63         dh_testversion 2
64         dh_testdir
65         dh_testroot
66         #
67         # build libminidom${major} package by moving files from minidom-dev
68         #
69 #       dh_movefiles -plibminidom$(major)             \
70 #       usr/lib/libminidom.so.$(major)        \
71 #       usr/lib/libminidom.so.$(version)
72 #       dh_movefiles get file contents from debian/*.files
73         dh_movefiles
74
75 #       dh_installdebconf       
76         dh_installdocs
77         dh_installexamples
78         dh_installmenu
79 #       dh_installemacsen
80 #       dh_installpam
81 #       dh_installinit
82         dh_installcron
83         dh_installmanpages
84         dh_installinfo
85         dh_undocumented
86         dh_installchangelogs ChangeLog
87         dh_link
88         dh_strip
89         dh_compress
90         dh_fixperms
91         # You may want to make some executables suid here.
92 #       dh_suidregister
93         dh_makeshlibs
94         dh_installdeb
95 #       dh_perl
96         dh_shlibdeps
97         dh_gencontrol
98         dh_md5sums
99         dh_builddeb
100
101 binary: binary-indep binary-arch
102 .PHONY: build clean binary-indep binary-arch binary install configure