]> matita.cs.unibo.it Git - helm.git/blob - pkg-matita/trunk/debian/patches/matita.conf.xml.in.dpatch
...
[helm.git] / pkg-matita / trunk / debian / patches / matita.conf.xml.in.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## matita.conf.xml.in.dpatch by Enrico Tassi <gareuselesinge@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
6
7 @DPATCH@
8 diff -urNad trunk~/matita/matita.conf.xml.in trunk/matita/matita.conf.xml.in
9 --- trunk~/matita/matita.conf.xml.in    2007-10-29 17:13:47.000000000 +0100
10 +++ trunk/matita/matita.conf.xml.in     2007-11-07 15:57:56.000000000 +0100
11 @@ -49,17 +49,17 @@
12      <!-- The following snippet is used by the helm team
13           note that user's tables are named diffrently from library tables,
14          so they can coexists on the same db -->
15 -
16 +<!--
17      <key name="metadata">@DBHOST@ matita helm none legacy</key>
18      <key name="metadata">@DBHOST@ public helm none library</key>
19      <key name="metadata">@DBHOST@ matita helm none user</key>
20 -
21 +-->
22      <!-- The following snippet it what you want to use a local sqlite db
23           and acess remotely to the coq library trought mowgli
24      <key name="metadata">@DBHOST@ matita helm none legacy</key>
25 +-->
26      <key name="metadata">file://$(matita.rt_base_dir) metadata.db helm helm library</key>
27      <key name="metadata">file://$(matita.basedir) user.db helm helm user</key>
28 -    -->
29  
30      <!-- 
31      If you have a large amount of metadata, you may be interested in using
32 @@ -90,11 +90,13 @@
33        (e.g. the Matita standard library)
34      "legacy" implies "ro"
35      -->
36 +<!--
37      <key name="prefix">
38        cic:/matita/
39        file:///projects/helm/library/matita_contribs/matita
40        ro
41      </key>
42 +-->
43      <key name="prefix">
44        cic:/matita/
45        file://$(matita.rt_base_dir)/xml/standard-library/
46 @@ -104,6 +106,7 @@
47        cic:/matita/
48        file://$(user.home)/.matita/xml/matita/
49      </key>
50 +<!--
51      <key name="prefix">
52        cic:/
53        file://@RT_BASE_DIR@/xml/legacy-library/coq/
54 @@ -119,5 +122,6 @@
55        http://mowgli.cs.unibo.it/xml/
56        legacy
57      </key>
58 +-->
59    </section>
60  </helm_registry>