]> matita.cs.unibo.it Git - helm.git/blob - pkg-matita/trunk/debian/patches/matita.conf.xml.in.dpatch
d4648c7b247eb26a3c2dacb51dd7a80b3c5a1f7f
[helm.git] / pkg-matita / trunk / debian / patches / matita.conf.xml.in.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## matita.conf.xml.in.dpatch by Enrico Tassi <gareuselesinge@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
6
7 @DPATCH@
8 diff -urNad trunk~/matita/matita.conf.xml.in trunk/matita/matita.conf.xml.in
9 --- trunk~/matita/matita.conf.xml.in    2007-10-28 14:10:17.000000000 +0100
10 +++ trunk/matita/matita.conf.xml.in     2007-10-28 14:41:45.000000000 +0100
11 @@ -50,9 +50,11 @@
12           note that user's tables are named diffrently from library tables, so that
13          they can coexists on the same db -->
14  
15 +<!--
16      <key name="metadata">@DBHOST@ public helm none legacy</key>
17      <key name="metadata">@DBHOST@ matita helm none library</key>
18      <key name="metadata">@DBHOST@ matita helm none user</key>
19 +-->
20  
21      <!-- The following snipset is used by the helm team to publish the matita
22           contributions
23 @@ -64,9 +66,9 @@
24      <!-- The following snippet it what you want to use a local sqlite db
25           and acess remotely to the coq library trought mowgli
26      <key name="metadata">@DBHOST@ matita helm none legacy</key>
27 +-->
28      <key name="metadata">file://$(matita.rt_base_dir) metadata.db helm helm library</key>
29      <key name="metadata">file://$(matita.basedir) user.db helm helm user</key>
30 -    -->
31  
32      <!-- 
33      If you have a large amount of metadata, you may be interested in using
34 @@ -97,11 +99,13 @@
35        (e.g. the Matita standard library)
36      "legacy" implies "ro"
37      -->
38 +<!--
39      <key name="prefix">
40        cic:/matita/
41        file:///projects/helm/library/matita_contribs/matita
42        ro
43      </key>
44 +-->
45      <key name="prefix">
46        cic:/matita/
47        file://$(matita.rt_base_dir)/xml/standard-library/
48 @@ -111,6 +115,7 @@
49        cic:/matita/
50        file://$(user.home)/.matita/xml/matita/
51      </key>
52 +<!--
53      <key name="prefix">
54        cic:/
55        file://@RT_BASE_DIR@/xml/legacy-library/coq/
56 @@ -126,5 +131,6 @@
57        http://mowgli.cs.unibo.it/xml/
58        legacy
59      </key>
60 +-->
61    </section>
62  </helm_registry>